Announcement

Collapse
No announcement yet.

Headwater turbo

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Headwater turbo

    Just got back from the first test of my head water. I installed a 2009 Yamaha nytro snowmobile engine that has a mcexspress turbo running 6 psi boost.
    engine is coupled to a Yamaha xl 1200 jet with trim and reverse. This thing is a rocket handles really well, just running the stock impeller, have ordered a steeper pitch impeller, can't wait for it to get here as I can slip the pump at anytime cruise at 5500 rpm 60 km/hr. I built my own water cooled exhaust manifold need to wrap the turbo and add some more vents gets pretty warm under the hood. Will add pics when I get a chance.

  • #2

    Comment


    • #3
      That’s bad ass! So many people ask about the nitro motors but this is the first I’ve seen one go in!
      pictures of the coupling?

      Comment


      • #4

        Comment


        • #5
          have been tossing around doing the same thing....Loooks good!!!
          I assume you are using a plate exchanger? how many plates if you are?

          Comment


          • #6
            I'am running a 20 plate and I boxed in one of the coolers that ran in the tunnel of the sled. Today engine temps were 70- 75 C.

            Comment


            • #7
              For testing purpose just unbolt the engine cover and leave it off?

              Comment


              • #8
                We'll work got in the way this past week, off now for a few days. Installed new impeller and added some more vents. Went to the lake to test, ran good for 10 min then started missing again, under hood temps were not hot at all so their goes that idea. Brought boat home a started doing some more checks and found #3 cyl injector was not working. Checked out harness and found loose wire in a connector for that injector. So will be testing in the morning.

                Comment


                • #9
                  Well she ran perfect, top speed of 70 km at 6200 rpm, Cruze 4500 rpm at 50 km, looks like it's is ready for river testing. 0 to 70km in less then 10 seconds. Really happy with how it turned out. Running a 14.5/17.5 pitch solas impeller. Just have to figure out how to trick the speedometer pick up to get the active 42 code to go away.

                  Comment


                  • #10
                    Hey Mike, any videos of the ride?

                    Comment

                    Working...
                    X